No textarea found with the given identifier (ID: ctl00_body_txtDetails)

Jan 21, 2011 at 3:20 PM

I just installed the product but when anyone clicks "New Ticket", or I click "View Ticket" or drill down on a created ticket I get the following pop-up:

No textarea found with the given identifier (ID: ctl00_body_txtDetails)

If you say "OK" to the pop-up it goes away and you can continue what you want to do. Can someone give me detailed instructions on how to fix this? I do not know any coding so please keep that in mind when replying.

Thanks!!

Coordinator
Jan 25, 2011 at 9:57 PM

Did you modify the source at all?  If you right click and do view->source, can you find an elements with the id="ctl00_body_txtDetails"?

Feb 2, 2011 at 2:21 PM

Hi Naspinki,

i am also getting the above error, i viewed the source code and found this

<textarea name="ctl00$body$txtDetails" rows="2" cols="20" id="body_txtDetails" style="height:100px;width:100%;">

Thanks

Gareth

 

Feb 2, 2011 at 3:04 PM

Hi Again,

i just changed the below script the red line to the green line in both the new Ticket.aspx and also the ticket.aspx files as i was getting the error in both.

Thanks

Gareth

 

<%--
Slick-Ticket v1.0 - 2008
http://slick-ticket.com
Developed by Stan Naspinski - stan@naspinski.net
http://naspinski.net
--%>
<%@ Page Title="New Ticket " Language="C#" MasterPageFile="~/MasterPage.master" ValidateRequest="false" AutoEventWireup="true" CodeFile="new_ticket.aspx.cs" Inherits="new_ticket" culture="auto" meta:resourcekey="PageResource1"%>

<asp:Content ID="Content1" ContentPlaceHolderID="head" Runat="Server">

    <script language="JavaScript" type="text/javascript" src="js/wysiwyg/scripts/wysiwyg.js" ></script>
    <script language="JavaScript" type="text/javascript" src="js/wysiwyg/scripts/wysiwyg-settings.js"></script>
     <script type="text/javascript">
         var mysettings = new WYSIWYG.Settings();

 WYSIWYG.attach('ctl00body_txtDetails', mysettings);
         WYSIWYG.attach('body_txtDetails', mysettings);

Coordinator
Feb 2, 2011 at 3:59 PM

That should have fixed it, is that it?

Feb 3, 2011 at 9:14 AM

it did in deed

Jan 12, 2012 at 1:28 PM

Don't make pnlimput.Visible = false;

use this code to hide that panel ...

pnlInput.Style.Add(HtmlTextWriterStyle.Display, "none");