AD Permisions problem after install

Apr 28, 2010 at 8:46 PM

WE are having a problem setting up AD groups after our initial install. 

We are getting the error messsage below.  I believe I setup the folder rights correctly.

Anyone have any suggestions?

Thank You in advance,

Tom Netti

 

Error refreshing the ad group xml file; this often has to be done from the web server itself and by an administrator with domain rights

Access to the path 'e:\web\servername\html\slickticket\app_data\adgroups.xml' is denied.
May 3, 2010 at 2:29 PM
I realized I still had anonymous on in IIS. I turned it off and allowed for windows auth and I able to login now, however I do not see the administration link. I am not sure how slick ticket decides who has admin rights. Do i need to reinstall? Any suggestions on where I can info about this?
May 5, 2010 at 8:07 AM

There is a table in the SlickTicket DB called Users.  The column you're looking for is "Is_Admin".  Set the value to "True" and you should then become an admin inside ST.

May 5, 2010 at 2:00 PM
Thank You very much!! That did the trick!!!!
May 5, 2010 at 4:24 PM

I successfully finished the setup steps, but when I click on the "fill out your profile" link in the "almost done" part of slick ticket setup, I get this:

 

Server Error in '/' Application.


 

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

Line 14:     <ContentTemplate>
Line 15:   
Line 16:         <asp:Panel ID="pnlInput" runat="server" DefaultButton="btnSubmit" >
Line 17:         
Line 18:             <fieldset class="inner_color"> 


Source File: c:\inetpub\slickticket\profile.aspx Line: 16

Stack Trace:

[SecurityException: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
   ASP.profile_aspx.__BuildControlpnlInput() in c:\inetpub\slickticket\profile.aspx:16
   ASP.profile_aspx.__BuildControl__control2(Control __ctrl) in c:\inetpub\slickticket\profile.aspx:13
   System.Web.UI.UpdatePanel.CreateContents() +97
   ASP.profile_aspx.__BuildControlup() in c:\inetpub\slickticket\profile.aspx:13
   ASP.profile_aspx.__BuildControlContent2(Control __ctrl) in c:\inetpub\slickticket\profile.aspx:11
   ASP.masterpage_master.__BuildControlbody() in c:\inetpub\slickticket\MasterPage.master:61
   ASP.masterpage_master.__BuildControldivMainContainer() in c:\inetpub\slickticket\MasterPage.master:59
   ASP.masterpage_master.__BuildControlmain_container() in c:\inetpub\slickticket\MasterPage.master:57
   ASP.masterpage_master.__BuildControlform1() in c:\inetpub\slickticket\MasterPage.master:28
   ASP.masterpage_master.__BuildControlTree(masterpage_master __ctrl) in c:\inetpub\slickticket\MasterPage.master:1
   ASP.masterpage_master.FrameworkInitialize() in c:\inetpub\slickticket\MasterPage.master.cs:912308
   System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +1305
   System.Web.UI.Page.get_Master() +69
   System.Web.UI.Page.ApplyMasterPage() +18
   System.Web.UI.Page.PerformPreInit() +58
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041511
   System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11041050
   System.Web.UI.Page.ProcessRequest() +91
   System.Web.UI.Page.ProcessRequest(HttpContext context) +240
   ASP.profile_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\2fb2e0f2\972b3dd1\App_Web_syr-pson.12.cs:0
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +599
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +171


 

Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927

May 5, 2010 at 6:44 PM

Which version are you (both) running?  (It's the numbers that follow "slickticket" on the ZIP file)

May 5, 2010 at 6:47 PM

i just downloaded it last week, so I assume it's the latest version?

May 5, 2010 at 6:49 PM

slickticket-28536

May 5, 2010 at 7:13 PM
slickticket-28536 I am no longer having a problem with AD. I was getting similar errors to wlazara but it was because I was had anonymous set to Yes in IIS for the website. When I turned anonymous off and selected "allow windows auth" on the website (and changed user table to set me as admin) my problems were resolved.
May 5, 2010 at 7:20 PM

how do you change the user table to set a user as admin, that is where i am lost

May 5, 2010 at 7:37 PM
As Sid described in an earlier post : There is a table in the SlickTicket DB called Users. The column you're looking for is "Is_Admin". Set the value to "True" and you should then become an admin inside ST. Does this help?
May 5, 2010 at 7:41 PM

no, if that helped I would be done by now lol :-)

I am definitely a SQL noob.  I mean I can pull up SQL mgmt studio and I see the table and the columns within it.  But I don't see anything that is just named "value" to change - and even if I did how do I make that apply to just one user?  I really am not sure what tool to use to get into and edit the actual SQL data...

 

any help would be great! thanks,

Wes

May 5, 2010 at 7:48 PM

OK, you need to be able to modify the SlickTicket tables which it sounds like you do not have the tools to do so.

Is there someone in your group that has SQL Service Management Studio (MS tool that allows user to make changes to tables) that can do this for you?

Anyone that does database work will have this tool.

You cannot set the flag on the User Table from within Slickticket unless you are an admin, which you currently are not.


From: wlazara [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 3:42 PM
To: Netti,Tom
Subject: Re: AD Permisions problem after install [slickticket:210923]

From: wlazara

no, if that helped I would be done by now lol :-)

I am definitely a SQL noob. I mean I can pull up SQL mgmt studio and I see the table and the columns within it. But I don't see anything that is just named "value" to change - and even if I did how do I make that apply to just one user? I really am not sure what tool to use to get into and edit the actual SQL data...

any help would be great! thanks,

Wes

Read the full discussion online.

To add a post to this discussion, reply to this email (slickticket@discussions.codeplex.com)

To start a new discussion for this project, email slickticket@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 5, 2010 at 7:57 PM

As I mentioned, I do have access to SQL Mgmt Studio, but I don't know what to do with it...  I assume that I don't need to actually edit the table itself, but rather somehow get into the data within the table and adjust that column for my user...  but I unfortunately don't know how to do that...

May 5, 2010 at 8:06 PM

First open Studio and browse to the user table:


Highlight dbo.users , right click and select OPEN Table

You will see something like this:

Notice the IS_admin column is set to True for certain users.

You will probably see False for your row in the Is_admin column.

Just change the False to True.

Hope this helps.

From: wlazara [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 3:57 PM
To: Netti,Tom
Subject: Re: AD Permisions problem after install [slickticket:210923]

From: wlazara

As I mentioned, I do have access to SQL Mgmt Studio, but I don't know what to do with it... I assume that I don't need to actually edit the table itself, but rather somehow get into the data within the table and adjust that column for my user... but I unfortunately don't know how to do that...

Read the full discussion online.

To add a post to this discussion, reply to this email (slickticket@discussions.codeplex.com)

To start a new discussion for this project, email slickticket@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 5, 2010 at 8:16 PM

sorry, your screenshots aren't showing up... but here is what I see when I right-click (no option for Open Table):

 

 

May 5, 2010 at 8:34 PM

I would click on the “Edit top 200 rows” option.

I am sure you only have a few entries your table. Then change Is-admin to True


From: wlazara [mailto:notifications@codeplex.com]
Sent: Wednesday, May 05, 2010 4:17 PM
To: Netti,Tom
Subject: Re: AD Permisions problem after install [slickticket:210923]

From: wlazara

sorry, your screenshots aren't showing up... but here is what I see when I right-click (no option for Open Table):

Read the full discussion online.

To add a post to this discussion, reply to this email (slickticket@discussions.codeplex.com)

To start a new discussion for this project, email slickticket@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

May 5, 2010 at 9:10 PM

ya tried that, this is what I get (seem to have no entries):

 

Coordinator
May 11, 2010 at 5:09 PM

No entries are made into that table until users start using the system.

Coordinator
May 11, 2010 at 5:10 PM

if you went through the install with your account, it should populate the first row with that account as an admin

May 12, 2010 at 12:48 AM

I dont' understand, this seems like a chicken and egg problem.  I can't go through setup properly because my account is not seen as an admin, so i have no permissions.  And in order to fix that, you are telling me to edit a table that won't be created until I can complete that process...

Coordinator
May 14, 2010 at 9:31 PM

It is a strange problem, havent heard of it yet, but all you need to do is to edit the table by hand, just make sure the userName is EXACTLY the correct AD name, ie: DOMAIN/my_username then set isAdmin to true