SlickTicket - Setup

Jan 6, 2010 at 4:29 PM

I was able to run the setup to create the databases successfully but when I click on "permissions"  or "settings" pages, I get the following error. Thank you so much

Exception Details: System.InvalidOperationException: Sequence contains no elements

Source Error:

Line 49:     public static user Get(dbDataContext db, string name)
Line 50:     {
Line 51:         return db.users.First(u => u.userName.Equals(name));
Line 52:     }
Line 53: 


Source File: c:\helpdeskticket\App_Code\Users.cs    Line: 51

Stack Trace:

[InvalidOperationException: Sequence contains no elements]
   System.Data.Linq.SqlClient.SqlProvider.Execute(Expression query, QueryInfo queryInfo, IObjectReaderFactory factory, Object[] parentArgs, Object[] userArgs, ICompiledSubQuery[] subQueries, Object lastResult) +847
   System.Data.Linq.SqlClient.SqlProvider.ExecuteAll(Expression query, QueryInfo[] queryInfos, IObjectReaderFactory factory, Object[] userArguments, ICompiledSubQuery[] subQueries) +113
   System.Data.Linq.SqlClient.SqlProvider.System.Data.Linq.Provider.IProvider.Execute(Expression query) +344
   System.Data.Linq.Table`1.System.Linq.IQueryProvider.Execute(Expression expression) +49
   System.Linq.Queryable.First(IQueryable`1 source, Expression`1 predicate) +301
   Users.Get(dbDataContext db, String name) in c:\helpdeskticket\App_Code\Users.cs:51
   admin_admin.Page_Load(Object sender, EventArgs e) in c:\helpdeskticket\admin\admin.master.cs:15
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627
Jan 6, 2010 at 8:17 PM

The system works great. I found my fault in IIS.  Windows authentication was disabled and anonymous access was enabled. so I disabled anonymous access and enabled windows authentication and that error message has gone.

May 5, 2014 at 1:40 PM
Edited May 5, 2014 at 2:04 PM
me to having the same issue and since three days i am trying to resolve it. but could not. i had gone through all steps exactly. but still the admin profile is not loading..