This project is read-only.

Install Issue - Profile Setup

Mar 5, 2009 at 4:20 PM
I'm getting this error during the setup when I attempt to update the profile:

Could it be that it's not reading from AD correctly?  How does it get this information?

I'm currently running this on a Win2003 server with SQL 2005 SP2, and a Win2008 Domain, all in a functional lab.  And yes, I can communicate with the DC just fine. 

As for the web app, are there special requirements for the Identity of the app pool?

Server Error in '/SlickTicket' Application.
--------------------------------------------------------------------------------

Index was outside the bounds of the array.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IndexOutOfRangeException: Index was outside the bounds of the array.


Source Error:


Line 33:     public static string userName()
Line 34:     {
Line 35:         return (HttpContext.Current.User.Identity.Name.Split(new char[] { '\\' }))[1];
Line 36:     }
Line 37:
 

Source File: c:\Inetpub\wwwroot\SlickTicket\App_Code\utils.cs    Line: 35

Stack Trace:


[IndexOutOfRangeException: Index was outside the bounds of the array.]
   utils.userName() in c:\Inetpub\wwwroot\SlickTicket\App_Code\utils.cs:35
   profile.Page_Load(Object sender, EventArgs e) in c:\Inetpub\wwwroot\SlickTicket\profile.aspx.cs:30
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +47
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1436

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

Mar 5, 2009 at 5:50 PM
Also, I did attempt to redo the entire installation - is there some IIS setting that I need to have configured?
Mar 6, 2009 at 10:39 AM
That error is fixed by getting the latest utils.cs file that I was telling you about earlier.

That error only seems to come up when the user is not logged into a domain, but shouldn't cause a problem.