This project is read-only.

Installing latest pre-release?

Mar 18, 2011 at 4:40 PM

Hi,

After having done a whole bunch of customising on a version 2 install of SlickTicket, I'm back and want to have a look at all the new stuff.

With that said, I feel like an idiot because I can't seem to install it, and I can't seem to find a guide for the pre-release version.

My main confusion stems from the fact that the downloaded zip file doesn't appear to be the root of the SlickTicket website.

I've tried pointing IIS 6 (server 2003 machine) at the WebUI subfolder, but I'm still having problems with it.  I'm getting the following error:

Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.
Line 24: <compilation debug="true" targetFramework="4.0">

I've installed .Net 4, and I'm still getting the error. 

Any ideas on what I might be doing wrong?  ...Do I need to build the solution first?

Mar 18, 2011 at 4:48 PM

I'm an idiot.  I've enabled ASP v4 in the IIS page and I've moved past that error.

Now I'm "battling" with a SQL connectivity error.  I'm probably doing something silly here as well.

Mar 18, 2011 at 4:52 PM
sid351 wrote:

I'm an idiot.  I've enabled ASP v4 in the IIS page and I've moved past that error.

Now I'm "battling" with a SQL connectivity error.  I'm probably doing something silly here as well.


Yep, I just had to add "/setup" to the end of the URL.  It wasn't redirecting me automagically.

Mar 18, 2011 at 5:09 PM

Hmm...

I'm getting a SQL connection error whenever I try to view a page that isn't

http://localhost/SlickTicket/setup/

http://localhost/SlickTicket/setup/build_database.aspx

or

http://localhost/SlickTicket/setup/followup.aspx

The tables were made successfully, and I'm using change-set 52723.

I've enabled named pipes, TCP/IP and VIA; I've checked and re-checked my connection string, and I've even tried using the SA account.

When I try connecting to the SQL instance with the exact same user name and password as I'm using in the connection string I get through just fine.

Anyone got any ideas as to what might be going wrong?

Mar 19, 2011 at 4:09 PM

I don't know what to tell you?  I just downloaded and set up from the downloads link and everything seems to work just fine.  This does not need to be built first, it is a website, not an project.  If your connection string works in one area, it should work in all areas...?  If the tables were made successfully, then your connection string should be fine?  Are you sure they are populated?  Did you go to the profile page first like the wizard says to?

SQL Connection errors are just that, your permissions/users/settings are wrong on your SQL server and/or connection string - I would recommend the asp.net forums or some sql forum, this problem happens a lot here and we have not had much success troubleshooting here.

Mar 21, 2011 at 11:14 AM
naspinski wrote:

1) This does not need to be built first, it is a website, not an project.  

2) If your connection string works in one area, it should work in all areas...?  

3) If the tables were made successfully...Are you sure they are populated?  

4) Did you go to the profile page first like the wizard says to?

1) Ok cool, I take it I point IIS to the WebUI folder, right?

2) That's what I thought

3) Yep

4) I can't

I've also tried deleting the DB, and the website files and re-extracting them & creating the DB with the web.config set to the SA account from the start.  I'm still getting the same problem.

Could it be because I'm trying to set it up on a server that isn't part of AD?  I'll see if I have a test machine that is part of a domain to try & let you know how I go.

Mar 21, 2011 at 11:42 AM

Nope, got exactly the same error on another machine that is part of the domain.

I'm actually quite baffled at this one.  Any chance you could send me a (password-free) copy of your web.config file please?

What platform are you running it on?  2003 / 08 / 08 R2?

Mar 21, 2011 at 11:45 AM
sid351 wrote:

Nope, got exactly the same error on another machine that is part of the domain.

I'm actually quite baffled at this one.  Any chance you could send me a (password-free) copy of your web.config file please?

What platform are you running it on?  2003 / 08 / 08 R2?

Are you using SQLExpress?

http://blogs.msdn.com/b/sql_protocols/archive/2007/05/13/sql-network-interfaces-error-26-error-locating-server-instance-specified.aspx

"First of all, you get this error message only if you are trying to connect to a SQL Server named instance. For default instance, you never see this."

I've got SQL Express installed as the default instance (i.e. I don't need to use .\SQLExpress)

I'm going to try installing an SQL Express instance so that it is named, and see how I get on.

Mar 21, 2011 at 12:05 PM

Ignore that.

My SQL Browser service was disabled, so I set it to automatic and started it.  

I then got a different error to do with the Network Service not being able to login.  Which I'm currently working on now.

I'll update when I get stuck, or when I fix it :)

Mar 21, 2011 at 12:49 PM

Ok, so I've managed to get a step further.

Here is how I did it:

I started the SQL Browser service running as Local System.

I installed SQL Express as a named instance called "SQLExpress" (what the installer defaults to).

I stopped my default instance of SQL.

Then I had to add "NT Authority\Network Service" as a Login to the SQLExpress instance, and then as a user with datareader, datawriter and owner mappings on the SlickTicket DB.

I set the web.config to .\SQLExpress.

 

Now I'm going to try the same thing with my default instance setup and see how I get on.

Mar 21, 2011 at 1:07 PM

Ok, I'm still getting the SQL Shared Memory Provider 40 error when I try using my default instance.

Is it possible that there is another data source / connection string somewhere else that has been hard-coded to look for .\SQLExpress?  Seeing as I needed to allow Network Service to login to the DB I'd guess that integrated security is on it as well, as that's the account IIS runs in by default.

 

sid351 wrote:

Ignore that.

My SQL Browser service was disabled, so I set it to automatic and started it.  

I then got a different error to do with the Network Service not being able to login.  Which I'm currently working on now.

I'll update when I get stuck, or when I fix it :)

I think that one was because I had installed SQL Express before starting the SQL Browser, and I had not stopped the SQL Express service from running (a.k.a. a red herring).

Also, I've just tried it with SQLExpress running with SQL Browser stopped and it works OK, so SQL Browser is not required.