This project is read-only.

Problem installing Slickticket on XP Pro on AD Domain

Apr 9, 2010 at 12:38 AM
Edited Apr 9, 2010 at 12:41 AM

I am trying to install slickticket to an xp pro box joined to a domain. I have done my best to follow the install of IIS but I think something is wrong.  I try to browse to my web site by IP or by name and I get an error that says this:

 

The website declined to show this webpage

 HTTP 403
 

Most likely causes:

  • This website requires you to log in.
 

What you can try:

 

Go back to the previous page.<noscript id="goBack"></noscript>

 

More information

Now I have recieved a popup once or twice to type in my user name and password but I had it setup to authenticate with the domain and I used my domain credentials...but it didnt work and now repeats this message. Under Authenticated Methods in IIS i have the box checked "Integrated Windows Authentication" and I have Anonymous disabled. In the file Web.Config I have the "Integrated Security=True" set.  And for the Security settings I have gone to the folder where the files are stored and right clicked and selected security and gave rights just as the instructions from SlickTicket say.

I am at a loss of what to do next. Any and All help is appreciated.

Apr 14, 2010 at 10:38 AM

XP Pro, isn't that IIS 5?

Have you got any Host Headers set up on that page, or is it a virtual directory?

Also, which version of SlickTicket are you using?

With the password, have you tried just putting your username and password, without any domain identifiers?

Apr 14, 2010 at 2:10 PM
I believe the native IIS for XP is IIS 5.1. The internet management console would not allow me to create a "Website" but it allowed me to create a virtual directory and that is what I did...I am inexperienced in this area so maybe thats my problem. 
I have installed the most recent on the website...just did it a few days ago.
Domain identifiers?  Do you mean if my user name is jmyers and the domain is ava then a username with a domain identifier would be ava\jmyers? Yes I have tried it both ways.  I set up a local user at first in SQL thinking I would not use windows Authentication...but then decided I needed to.  Is that what is causing my trouble?  I created a user with the same name as my domain user account...could that do it?

At this point I have jacked around with it so much I have lost track as to what the different things I have done "trying things". I am almost considering wiping out it and starting over.  If I did that would I be able to just uninstall SQL and IIS and start fresh or do I need to reload the OS?


On 4/14/2010 4:38 AM, sid351 wrote:

From: sid351

XP Pro, isn't that IIS 5?

Have you got any Host Headers set up on that page, or is it a virtual directory?

Also, which version of SlickTicket are you using?

With the password, have you tried just putting your username and password, without any domain identifiers?


Apr 16, 2010 at 4:52 PM

Firstly, sorry about the delay in responce, I forgot to tick the "email me" box.

xcalibursword wrote:
I believe the native IIS for XP is IIS 5.1. The internet management console would not allow me to create a "Website" but it allowed me to create a virtual directory and that is what I did...I am inexperienced in this area so maybe thats my problem. 
I have installed the most recent on the website...just did it a few days ago.
Domain identifiers?  Do you mean if my user name is jmyers and the domain is ava then a username with a domain identifier would be ava\jmyers? Yes I have tried it both ways.  I set up a local user at first in SQL thinking I would not use windows Authentication...but then decided I needed to.  Is that what is causing my trouble?  I created a user with the same name as my domain user account...could that do it?

At this point I have jacked around with it so much I have lost track as to what the different things I have done "trying things". I am almost considering wiping out it and starting over.  If I did that would I be able to just uninstall SQL and IIS and start fresh or do I need to reload the OS?

 In XP it is 5.1, and you're only allowed 1 "web site" but unlimited (I think) virtual directories.  That's by MS design...but I digress.

When you say the most recent one, what's the version number of the ZIP?

You understood exactly what I meant by domain identifiers.

Could you post a copy of your connection string in the WEB.CONFIG file?  PLEASE REMOVE OR CHANGE YOUR PASSWORD BEFORE DOING SO THOUGH.

If you want to wipe clean, all you need to do is delete the SlickTicket Database, and the Virtual Directory.

Also, what is the URL you're entering into your web browser?  It should be something like http://<NameOfXPMachine>/SlickTicket if that doesn't work try http://<NameOfXPMachine>/SlickTicket/Setup

AFAIK, the SQL user and your domain user shouldn't cause any issues, but I could be wrong.

 

PS, I've ticked the box this time :)

Apr 20, 2010 at 11:48 PM

Here is the .config file. 

Its version "slickticket-28536".

I am lost now on this project.  I had to put it down for a while due to other pressing issues...so now I have no idea what I have done.

I extracted the Slickticket files to

C:\Inetpub

I have SQL Server 2008 installed

If I look in my IIS Snapin I see this layout

IIS

    - Slickticket (Local computer)

           ->Websites

                    ->AvaHelpDesk

                           ->Setup

                           ->Attachments

so on....

When I right Click on "Websites" and go to properties, then select directory security.  I un-check Anonymous access and check "Integrated Windows Authentication"

When I right Click on "AvaHelpdesk" and go to properties, then select directory security.  I un-check Anonymous access and check "Integrated Windows Authentication"

The home Directory under AvaHelpDesk is set to C:\Inetpub with or without Read/Write boxes check (either checked or unchecked neither one works)

When I look at the databases i see:

-  SLICKTICKET\SQLEXPRESS

      -> Databases

              -> System Databases

             -> SlickTicket

I have given Rights to the three folders as instructed in the install

I have tried to access website by http://localhost/setup or even http://SlickTicket/setup

I have tried using the full computer name slickticket.Schoolname.k12.mo.us...I have tried just http://Localhost/

 

 

<?xml version="1.0"?>
<!--
    Note: As an alternative to hand editing this file you can use the
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in
    machine.config.comments usually located in
    \Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
    <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
                <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
                <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
                    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
                    <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
                    <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
                    <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
                </sectionGroup>
            </sectionGroup>
        </sectionGroup>
    </configSections>
    <appSettings/>
    <connectionStrings>
        <add name="SlickTicket" connectionString="
                  Data Source=.\SQLEXPRESS;          
                  Initial Catalog=SlickTicket;
                  Integrated Security=True"
                  providerName="System.Data.SqlClient"/>
    </connectionStrings>
    <system.web>
        <globalization uiCulture="auto" />
        <!--
            Set compilation debug="true" to insert debugging
            symbols into the compiled page. Because this
            affects performance, set this value to true only
            during development.
        -->
        <compilation debug="true">
            <assemblies>
                <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                <add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/></assemblies>
        </compilation>
        <!--
            The <authentication> section enables configuration
            of the security authentication mode used by
            ASP.NET to identify an incoming user.
        -->
        <authentication mode="Windows"/>
        <!--
            The <customErrors> section enables configuration
            of what to do if/when an unhandled error occurs
            during the execution of a request. Specifically,
            it enables developers to configure html error pages
            to be displayed in place of a error stack trace.
        -->
        <customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm"/>
            <error statusCode="404" redirect="FileNotFound.htm"/>
        </customErrors>
        <pages>
            <controls>
                <add tagPrefix="ctrl" tagName="AdminPanel" src="~/controls/AdminPanel.ascx"/>
                <add tagPrefix="ctrl" tagName="SecurityLevels" src="~/controls/security_levels.ascx"/>
                <add tagPrefix="ajax" namespace="AjaxControlToolkit" assembly="AjaxControlToolkit"/>
                <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            </controls>
        </pages>
        <httpHandlers>
            <remove verb="*" path="*.asmx"/>
            <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
        </httpHandlers>
        <httpModules>
            <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </httpModules>
    </system.web>
    <system.codedom>
        <compilers>
            <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
                <providerOption name="CompilerVersion" value="v3.5"/>
                <providerOption name="WarnAsError" value="false"/>
            </compiler>
            <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
                <providerOption name="CompilerVersion" value="v3.5"/>
                <providerOption name="OptionInfer" value="true"/>
                <providerOption name="WarnAsError" value="false"/>
            </compiler>
        </compilers>
    </system.codedom>
    <!--
        The system.webServer section is required for running ASP.NET AJAX under Internet
        Information Services 7.0.  It is not necessary for previous version of IIS.
    -->
    <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
            <remove name="ScriptModule"/>
            <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </modules>
        <handlers>
            <remove name="WebServiceHandlerFactory-Integrated"/>
            <remove name="ScriptHandlerFactory"/>
            <remove name="ScriptHandlerFactoryAppServices"/>
            <remove name="ScriptResource"/>
            <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </handlers>
    </system.webServer>
    <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
                <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
            </dependentAssembly>
            <dependentAssembly>
                <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
                <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
</configuration>

Apr 21, 2010 at 10:10 AM
xcalibursword wrote:

Its version "slickticket-28536".

I am lost now on this project.  I had to put it down for a while due to other pressing issues...so now I have no idea what I have done.

I extracted the Slickticket files to C:\Inetpub

IIS

    - Slickticket (Local computer)

           ->Websites

                    ->AvaHelpDesk

                           ->Setup

                           ->Attachments

so on....

When I right Click on "Websites" and go to properties, then select directory security.  I un-check Anonymous access and check "Integrated Windows Authentication"

When I right Click on "AvaHelpdesk" and go to properties, then select directory security.  I un-check Anonymous access and check "Integrated Windows Authentication"

The home Directory under AvaHelpDesk is set to C:\Inetpub with or without Read/Write boxes check (either checked or unchecked neither one works)

I have tried to access website by http://localhost/setup or even http://SlickTicket/setup

I have tried using the full computer name slickticket.Schoolname.k12.mo.us...I have tried just http://Localhost/

        <add name="SlickTicket" connectionString="
                  Data Source=.\SQLEXPRESS;          
                  Initial Catalog=SlickTicket;
                  Integrated Security=True"
                  providerName="System.Data.SqlClient"/>

Ok, that all looks good.

Try going to http://localhost/AvaHelpDesk/Setup

If that doesn't work, would you mind posting more info (preferably a screenshot or two) of the IIS Configuration?